[Atari] 800XL PAL

Reparaciones, modificaciones, especificaciones, manuales técnicos , etc.
Responder
Avatar de Usuario
vitoco
Mensajes: 1955
Registrado: Lun Ene 28, 2013 5:47 pm
Contactar:

[Atari] 800XL PAL

Mensaje por vitoco » Dom Ene 03, 2016 8:07 pm

Después de todo el ajetreo de fin de año, logré sentarme a probar la placa 800XL PAL que me enviaron los amigos de ABBUC desde Alemania.

Imagen

Como recordarán, esta placa además de ser norma PAL en lugar de NTSC, incluye un mod estéreo, una ampliación de memoria de 512K y el mod SuperVideo (que no sé exactamente qué hace o mejora).

Lo primero que debía hacer era poner la placa en una cáscara 800XL con teclado operativo, así que hice el trasplante de placa madre al 800XL que tenía destinado a los mods de SDrive y de memoria a 320K. Pero me topé con un problemita de espacio... como toda esta placa está con sockets y los mods también, no solo no pude volver a ponerle la jaula de Faraday, sino que además la ampliación de memoria presionaba la parte trasera del teclado en la cubierta superior, haciendo casi imposible volver a cerrar el Atari. Igual lo hice. :twisted:

El segundo paso era conectarlo a la tele y encenderlo... pero no a cualquier tele, debía ser una que soportara PAL. Primero intenté con la tele LED de la pieza de los niños, pero no logré ninguna imagen. Después me fui al LED de mi dormitorio, el que sí había chequeado que soportaba PAL, pero sin ninguna documentación al respecto. Ahí logré obtener imagen en blanco y negro (típico al conectar en un televidor NTSC), pero con una extraña matriz tipo tablero de ajedrez... imagino que se debe a alguna aberración por culpa del upscaling del televisor a 1080p. No pude hacer más experimentos porque mi wife estaba viendo uno de sus programas y la prueba duró lo mismo que los comerciales. Mientras esperaba la siguiente tanda publicitaria, recordé que a mis pies había un baúl que tenía guardado un LCD de 7" o menos, y que era multinorma. Me fui con todo al comedor e hice las conexiones... ¡Yupi! Tenía imagen en blanco y negro (pero con downscaling... todavía no cacho qué resolución tiene esa tele, que además es widescreen). Con el control remoto en mano cambié la configuración de la entrada a PAL-M, luego a PAL-N y finalmente a PAL a secas, siendo en esta última donde aparecieron los colores.

Vamos al tercer paso: probar el estéreo. Lo primero que se me ocurrió fue cargar un juego, y para eso recordaba que tenía el Draconus en stereo. Y para cargarlo tenía 3 alternativas: usar la disketera 1050, el SIO2SD o el SIO2PC-USB. La primera la descarté porque no tenia el Draconus en diskette sino que en CD-ROM, y la segunda también la descarté porque en la penúltima junta saqué la tarjeta SD del SIO2SD y no tengo idea dónde la dejé. La tercera era intentar el SIO2PC-USB que me llegó junto a la placa y que aún no probaba. Revisé que tuviera el cable USB adecuado y crucé los dedos por que Windows 10 x64 reconociera el hardware y le asignara una COM, lo que finalmente sucedió. Instalé RespeQt y después de jugar con las configuraciones (tomó por defecto las que tenía con AspeQt cuando el notebook era Windows 7 x64 y me daba cabezazos buscando un driver compatible con el SIO2VCP de Xt5), logré que el Atari booteara el ATR de Draconus. Cuando cargó, partió el juego y efectivamente estaba en estéreo. Pero no lo pude jugar porque el joystick no estaba al 100%.

Ahora tengo que ir por el cuarto paso: probar la memoria RAM y la compatibilidad con RAMDISK y otros programas como mi último SITRE... el resultado de eso en el próximo reporte.

Avatar de Usuario
vitoco
Mensajes: 1955
Registrado: Lun Ene 28, 2013 5:47 pm
Contactar:

Re: [Atari] 800XL PAL

Mensaje por vitoco » Dom Ene 03, 2016 8:52 pm

En la primera prueba del 4to paso, usé SITRE 3.02, y reconoció la misma cantidad de bancos que en el emulador: 17, equivalente a 272K (278.526 bytes). Esto quiere decir que tomó 16 bancos de la ampliación (256K) y 1 banco (16K) de la RAM original del 800XL (donde se hace el banqueo)... O sea, al menos se está comportando como una RAMBO 320K, sin conflictos entre la RAM real y la extendida (lo que sucede en la ampliación de Buchholz y la de Newell, en donde 4 de los 16 bancos corresponden a los 64K de memoria real).

Seguiré investigando para ver cómo acceder a los otros 256K adicionales. :1313:

Avatar de Usuario
SpaceInvader
Mensajes: 217
Registrado: Jue Jul 17, 2014 4:01 pm
Contactar:

Re: [Atari] 800XL PAL

Mensaje por SpaceInvader » Lun Ene 04, 2016 2:17 am

Que bien, espero que documentes bien todo esto con fotos, videos y análisis tecnicos exclusivos jaja

Debe ser el único Atari PAL europeo que hay en Chile, una verdadera rareza. Es probable que no se vea en un TV PAL argentino.

Avatar de Usuario
133MHz
Mensajes: 575
Registrado: Mar Ene 22, 2013 12:28 am
Ubicación: Santiago
Contactar:

Re: [Atari] 800XL PAL

Mensaje por 133MHz » Lun Ene 04, 2016 3:58 am

SpaceInvader escribió:Debe ser el único Atari PAL europeo que hay en Chile
En juntas pasadas de otras comunidades locales he visto equipos A8 PAL de propiedad de los asistentes, para correr los demos polacos.
Spoiler: MOSTRAR
Por cierto, esto me recuerda un argumento que he tenido con más de alguno. Chile podrá ser chico, pero con lo globalizado que está todo y lo difundido que está el hobby ya nada es único, hasta en los nichos más pequeños hay competencia local considerable. Con el tiempo me he dado cuenta que hasta en lo más rebuscado no estoy para nada solo.
SpaceInvader escribió:Es probable que no se vea en un TV PAL argentino.
Alemania es de norma análoga B/G (ancho de canal 7MHz, sonido en 5.5MHz, subportadora de color 4.433619 MHz) mientras que la norma N argentina es de 6MHz y sonido en 4.5MHz igual que la M americana, con la subportadora de color en 3.582056 MHz, por lo que en un TV binorma argentino definitivamente se ve en blanco y negro (AV) y sin sonido (RF).

Avatar de Usuario
vitoco
Mensajes: 1955
Registrado: Lun Ene 28, 2013 5:47 pm
Contactar:

Re: [Atari] 800XL PAL

Mensaje por vitoco » Lun Ene 04, 2016 9:18 am

133MHz escribió:Alemania es de norma análoga B/G (ancho de canal 7MHz, sonido en 5.5MHz, subportadora de color 4.433619 MHz) mientras que la norma N argentina es de 6MHz y sonido en 4.5MHz igual que la M americana, con la subportadora de color en 3.582056 MHz, por lo que en un TV binorma argentino definitivamente se ve en blanco y negro (AV) y sin sonido (RF).
Con lo emocionado que estaba con el mod de estéreo, no noté que no había audio en la TV, sino que sólo en los audífonos que conecté en el minijack que traía soldado. Pensé que había dejado desconectado el conector del audio de la salida A/V del XL, pero al desmontar todo me di cuenta que no. Ahora pienso que tal vez pasó algo como lo que Emiliano describe de las portadoras... o que el mod estéreo se pitea ese canal... otra cosa más que investigar. :?

Respecto de la ampliación de memoria, caché que hay unos pines de configuración impresos en la placa, y que debería hacer puentes para cambiar la compatibilidad con diversos mods, incluyendo el de Buchholz y el Newell. Aún estoy buscando documentación de eso... y ojalá que no esté en alemán. :roll:

Avatar de Usuario
vitoco
Mensajes: 1955
Registrado: Lun Ene 28, 2013 5:47 pm
Contactar:

Re: [Atari] 800XL PAL

Mensaje por vitoco » Vie Ene 08, 2016 1:03 am

vitoco escribió:Con lo emocionado que estaba con el mod de estéreo, no noté que no había audio en la TV, sino que sólo en los audífonos que conecté en el minijack que traía soldado. Pensé que había dejado desconectado el conector del audio de la salida A/V del XL, pero al desmontar todo me di cuenta que no. Ahora pienso que tal vez pasó algo como lo que Emiliano describe de las portadoras... o que el mod estéreo se pitea ese canal... otra cosa más que investigar. :?
La cosa era más simple de lo que pensaba... si conecto unos audífonos al conector estéreo, se deshabilita el audio mono (original) del conector DIN. :1313:

Responder